iCloud: Supported System Requirements

iCloud requires an Apple ID, an active Internet connection, and up to date software. If you meet the recommended system requirements below, you can take advantage of the latest iCloud features and get the best overall experience. To see the minimum requirements for additional features, you can click the link below.

iPhone, iPad, and iPod touch
· iOS 10
· iWork for iOS (Pages 2.5, Numbers 2.5, Keynote 2.5)
Mac Computer
· macOS Sierra
· iTunes 12.5
· Safari 9.1 or later, Firefox 22 or later, or Google Chrome 28 or later
· iWork for Mac (Pages 5.5, Numbers 3.5 , Keynote 6.5)
MINIMUM for your iPhone, iPad or iPad Touch
* iOS 5
Mac Computer
* OS X Lion 10.7.2
* iTunes 10.5
* iPhoto'11 (version 9.2) or Aperture 3.2 (for Photo Stream)
* Safari 5.1.1 or later (for Bookmarks)

PC Requirements (See full requirements here)

Close Window